FANDOM


SLADE3's interface is a standard Tabbed Document Interface. For SLADE3, a "document" is an archive (such as a WAD or PK3 file), and the data segments in an archive are entries.

The interface is comprised of the following elements:

  1. The menus
  2. The toolbar
  3. The main window, containing
  1. The tab bar
  2. The entry list
  3. The entry panel
  1. The archive manager (Ctrl-1)
  2. The console (Ctrl-2)

Menus and toolbarEdit

They allow the usual functions of a TDI application: the File menu lets you create a New archive, Open one, Save it, Close it, and so on. The Editor menu allows access to option configuration, most importantly creating a list of "base archives" and selecting which one to use. (The base archive is typically the IWAD of the game for which the edited archive is a mod.) The Archive menu lets you change the currently selected archive (creating or importing entries, opening the texture editor, etc.), while the Entry menu allows to change the currently selected entry (renaming it, deleting it, copying it, etc.). The View menu lets you toggle display of the Archive Manager and the Console. The Help menu contains the usual About box and a link to this wiki.

The toolbar offers quick links to many of the most-frequently used menu commands.

The main windowEdit

At the top of the main window is a tab bar allowing you to quickly select any of the opened archives. At startup, it contains a single tab, with a welcome screen in it. If an archive tab is selected, the main window is split into an entry list for the selected archive, which lets you select entries from this archive, and an entry panel, which changes depending on the nature of the entry or entries that are selected.

Many functions are available only through the context menu (right-click) of the entry list, or through buttons in the entry panel.

The archive managerEdit

The archive manager contains a file browser tab that allows you to open various archives (as an alternative to the Open menu) and an Archives tab that lists the currently open archives, and the maps that they contain. By default, closing an archive's tab does not close the archive itself, but if an archive disappears from the Archive Manager's Archives tab, it is indeed closed.

Display of the archive manager can be toggled on and off with the View menu or the Ctrl-1 keyboard shortcut.

The consoleEdit

The console displays various messages when certain actions are performed. It is mostly useful as a debugging tool for SLADE3 itself.

Display of the console can be toggled on and off with the View menu or the Ctrl-2 keyboard shortcut.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.